Mike Chaney's Tech Corner
June 21, 2021, 01:57:37 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Feb 2013: Qimage Ultimate Challenges... have fun and explore features!
 
   Home   Help Search Login Register  

Professional Photo Printing for Windows
Print with
Qimage and see what you've been missing!
Pages: [1]
  Print  
Author Topic: Incorrect Colour Profile Embedded in Email Copies  (Read 345 times)
Terry-M
The Honourable Metric Mann
Forum Superhero
*****
Posts: 3205



View Profile WWW
« on: May 04, 2021, 04:06:59 PM »

One for Mike I expect.
Recently I've noticed if I edit and make E-mail copies of images from my Sony phone, they have Adobe RGB embedded in the image.
The original images do not have an embedded profile and show sRGB in QU without an asterisk, as expected.
If I use the ICC override to sRGB in the Editor, they still end up as Adobe RGB when an E-mail copy is made.

I don't take that many photos with my phone but all those taken this year have the problem. Prior to that, 2020 and earlier they are ok when emails copies were made.

Any ideas what's going on please?

Terry
Logged
admin
Administrator
Forum Superhero
*****
Posts: 3305



View Profile Email
« Reply #1 on: May 04, 2021, 08:53:16 PM »

Would you be able to put a sample copy on Google Drive?  It could be an issue with the formatting of the files.  I've seen a few cases where files can be formatted incorrectly such as the embedded JPEG thumbnail having its own profile separate from the main image: this is not allowed via the JPEG spec as thumbnails are not allowed to have a color space, creating a file with two embedded color spaces.  So I'd have to see if the image has any formatting issues that would affect this.

Regards,
Mike
Logged
Terry-M
The Honourable Metric Mann
Forum Superhero
*****
Posts: 3205



View Profile WWW
« Reply #2 on: May 05, 2021, 06:42:31 AM »

Hi Mike,
Thanks for your reply.
Here is a link for 2 images, one taken late 2020 (DSC_3200), the other in early 2021 (DSC_3288).
DSC_3200 email copy converts to sRGB as it should but DSC_3288 incorrectly converts to Adobe RGB.

https://drive.google.com/drive/folders/1pwp4m-1DtIgi0aSw3VVng5OijBJ6Qg7e?usp=sharing

Terry
Logged
admin
Administrator
Forum Superhero
*****
Posts: 3305



View Profile Email
« Reply #3 on: May 05, 2021, 02:27:10 PM »

Thanks.  I got both images.  Unfortunately (for me), I'm not getting the same problem.  Both images convert to sRGB when I use the email features.  I tried "Send Via Email" from thumbnails and "Create Email/Web Copies" from the live view and both converted images show as sRGB.  Do you have any filters on the images that might change things?

Regards,
Mike
Logged
Terry-M
The Honourable Metric Mann
Forum Superhero
*****
Posts: 3205



View Profile WWW
« Reply #4 on: May 05, 2021, 06:15:37 PM »

Hi Mike,
Thanks for checking.
Do you know what, I cannot reproduce the problem today at all - weird!  Huh
Sorry if I wasted your time, I will check again in a day or two with some new photos from my phone.
Terry
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!